Android plugin is not compatible with Gradle

今天在更新Android Studio至2.2Beta3,打开项目突出出现了异常:

Error:Android plugin 2.1.0 is not compatible with Gradle 2.14.1.
Fix plugin version and sync project

Open Documentation

打开上面提示的界面,看到如下信息:

Android Gradle Plugin Requires Gradle

由上图可以看出,不同的Android Gradle Plugin版本仅支持对应的Gradle版本.

2.1.0的Gradle Plugin仅支持Gradle 2.10 - 2.13,而我使用的是2.14.1所以报错啦.

以下为修复步骤:

  1. 修改确认Project build文件的Gradle Plugin版本
    请输入图片描述
  2. 确认Setting中的Gradle配置
    请输入图片描述
  3. 确认Project Gradle版本配置
    请输入图片描述

上图红框出版本应改为2.10 ~ 2.13

  1. 重新build一下项目,问题解决.
Last modification:May 29th, 2017 at 01:54 pm
If you think my article is useful to you, please feel free to appreciate

Leave a Comment